I’m currently battling trying to get gambas2 installed on one of my raspis so I can try out DomotiGa http://www.domotiga.nl

sudo apt-get install gambas2

Looks to install AOK but when trying to run from the desktop nothing happens and when trying to run from the terminal gives:

pi@raspberrypi:~$ gambas2
Segmentation fault

Googling around suggested synaptic has better dependency checking so I tried again from scratch. This gave me 3 errors (404 page not found for openssl, libcurl3-gnutls & postgresql). I installed these 3 packages using apt-get, fired synaptic up and was able to complete the gambas2 installation without any errors/warnings.

But alas, firing up gambas2 presents the same lack of activity from the desktop and segmentation fault error from the terminal.

Another search result suggested trying the development / testing version of gambas2 from the wheezy repository. Unfortunately (unless I did something wrong) it appears the same version is in both the stable repository- doh!
*EDIT* I just found out that I could have figured this out pretty easily by browsing: http://packages.debian.org/search?searchon=names&keywords=gambas2 which would also have pointed out the fact that there is a third repository: Unstable (sid). This doesn’t have the latest 2.24 but does have 2.23 (I may try this at some point to see if it is possible to avoid the hassle of compiling yourself)

Next to try compiling from source: http://sourceforge.net/projects/gambas/files/gambas2/ (which is nearly complete- but will inevitably cause me to pull out my hair!)

L

Advertisements